class DiAccelo(DiSkillV2):
def __init__(self, app: MatrixGUI1.App):
super().__init__()
self.brain: Brain = app.brain
self.app: MatrixGUI1.App = app
self._tg:TimeGate = TimeGate(2)
self._acceled:bool = False
def input(self, ear: str, skin: str, eye: str):
if ear == "accelo":
self._tg.open()
self._acceled = True
self.app.tick_interval = 2000 # accel tick, emp it up!
self.setSimpleAlg("emp it up")
return
if self._acceled:
if self._tg.isClosed():
self._acceled = False
self.app.tick_interval = 3000
figure it outthis is a new category of skills, maybe an additional naming convention is needed?
shit in the ass